sv.phhsnews.com


sv.phhsnews.com / Hur man tittar på Hulu på Ubuntu och andra Linux-distribueringar

Hur man tittar på Hulu på Ubuntu och andra Linux-distribueringar


Hulu fungerar inte ute i modern Linux-distribution. Medan Netflix "fungerar bara" om du använder Google Chrome har Hulu DRM blivit gammal och klumpig. Du kan få Hulu att arbeta på Linux, men det kommer att ta lite tweaking.

Det var inte alltid så svårt. Tillbaka när Netflix gjorde livet svårt för Linux-användare, erbjöd Hulu även en Linux-skrivbordsapp. Men den stationära appen har nu upphört. Hulu bygger på Adobe Flash, och Adobe Flash DRM-kod skiljer sig åt på Linux.

Du måste använda Firefox

RELATED: Använda Firefox på Linux? Din Flash Player är gammal och föråldrad!

Här är problemet: Hulu bygger på den gamla Adobe Flash DRM-koden som kräver ett Linux-bibliotek som kallas HAL. Men den här gamla HAL-mjukvaran är ganska gammal och har inte installerats som standard på moderna Linux-distributioner i åratal. Du måste installera kompatibilitetspaket som tillåter den här HAL-baserade DRM-funktionen.

Du måste också använda Mozilla Firefox för att se Hulu. Den gamla HAL-baserade DRM fungerar bara i den äldre versionen av Linux Flash-plug-in Firefox-erbjudanden. Den nyare PPAPI-baserade Flash Player (ingår i Google Chrome) fungerar inte med Hulus gamla DRM-kod.

Ja, det betyder att du måste titta på Netflix i Google Chrome och Hulu i Mozilla Firefox. Är inte livet grand?

Steg ett: Installera Flash för Firefox

Först måste du installera Flash Player-plugin-modulen för Firefox. Om du inte har installerat Flash ännu ser du ett meddelande som säger att Hulu behöver Flash installerat när du försöker titta på det.

Du kan vanligtvis installera Flash från din Linux-distributions programvaruförråd. Till exempel, på Ubuntu, öppna Ubuntu Software Center och leta efter "flash". Installera "Adobe Flash plug-in" -programvaran.

Var noga med att du installerade Flash plugin-designen "för Mozilla," "Firefox" eller "NPAPI" -versionen av plugin-modulen. "PPAPI" eller "Chromium" -versionen av Flash fungerar bara med Chrome och Chrome-baserade webbläsare.

Steg två: Installera det gamla HAL-biblioteket

När du har Firefox och Flash-plugin-programmet för Firefox installerat , kan du gå till Hulu hemsida och försöka spela en video. Dock kommer du förmodligen att se ett felmeddelande när du gör det. Felmeddelandet säger "Det uppstod ett problem med att spela detta skyddade innehåll. (Felkod: 2203) ". Hulu kommer att fråga dig om att HAL-paketet är installerat, ta bort flashcache och återställ licensfiler.

Hulu länkar dig till en Adobe-sida som rekommenderar att du installerar paketet "hal" men det här paketet är inte längre jämnt närvarande för installation på moderna versioner av Ubuntu och andra moderna Linux-distributioner.

I stället för att du installerar en version av hela HAL-paketet - från "zombie HAL PPA" som det är känt i Ubuntu-kretsar, kommer vi att rikta dig till en mer lättlösning.

Martin Wimpress, projektledning för Ubuntu MATE, ger en "hal-flash" PPA som ger allt du behöver för att spela upp DRM-skyddat Flash-innehåll utan att installera hela HAL-lagret.

För att installera den här mjukvaran måste du lägga till denna PPA i ditt Ubuntu-system (detta ska också fungera på Linux Mint och andra Ubuntu-härledda distributioner). Öppna en terminal från bindestreck och klistra in eller skriv följande kommandon i ordning, tryck på Enter efter varje. Det första kommandot lägger till PPA, den andra nedladdningsinformationen om paketen i den, och den tredje installerar HAL-biblioteket.

sudo add-apt-repository ppa: flexiondotorg / hal-flash
sudo apt-get update
sudo apt-get install libhal1-flash

Om du använder en annan Linux-distribution - det vill säga något annat än Ubuntu, Linux Mint eller något som härrör från Ubuntu - måste du jaga ett HAL-paket för Flash tillhandahålls för din Linux-distribution. Det kan vara en del av din Linux-distributionens paketförråd, eller det kan vara i ett tredje partförteckning som det är för Ubuntu. När det är installerat, besök Hulu i Firefox, försök att spela en video igen, och det ska nu fungera istället för att visa dig ett "skyddat innehåll" felmeddelande.

Om du fortsätter att se ett felmeddelande kan du behöva stänga Firefox och starta om det. Om det inte fungerar kan du försöka starta om datorn helt innan du fortsätter.

Det här har varit ett problem i många år nu. Adobe-sidan säger att HAL måste installeras på versioner 10.x och uppe i Ubuntu - det hänvisar till versioner av Ubuntu släpptes hela tiden tillbaka 2010.


Adobe vill inte längre utveckla Flash på Linux. Den verkliga lösningen här kommer inte när Adobe fixar sin Flash DRM. Istället behöver Hulu byta till modern HTML5-baserad videouppspelning, som Netflix använder i Google Chrome. Innan de gör det, kommer Linux-uppspelning lite besvär.


Så här återställer du fabriken och avinstallerar din nästtermostat

Så här återställer du fabriken och avinstallerar din nästtermostat

Om du byter ut din nästermostat eller flyttar och vill ta den med dig till din nya plats, så här återställer du fabriksnivån och avinstallera det. Även om du håller din nästtermostat, men bara flyttar den till ett nytt hus, behöver du fortfarande fabriksåterställa det, eftersom Wi-Fi-nätverket kommer att vara annorlunda och mer Viktigt är att uppvärmnings- och kylsystemen i det nya huset kan skilja sig från vad din Nest Thermostat ursprungligen hade ställt in.

(how-to)

Vad är en VPN, och varför skulle jag behöva?

Vad är en VPN, och varför skulle jag behöva?

Med ett VPN eller Virtual Private Network kan du skapa en säker anslutning till ett annat nätverk via Internet. VPN kan användas för att få åtkomst till regionbegränsade webbplatser, skydda din surfaktivitet från nyfikna ögon på offentlig Wi-Fi och mer. VPN skickar i princip all din nätverkstrafik till nätverket, vilket är där fördelarna - som att komma åt lokala nätverksresurser på distans och kringgå Internet censur - allt kommer ifrån.

(how-to)